ЕГЭ по информатике Часть 2. Основная волна 16.06.2016. Вариант 52.

ЕГЭ по информатике Часть 2. Основная волна 16.06.2016. Вариант 52.

1. Ученик написал программу, определяющую, какой степенью числа 5 является введенное. Например, для 25 это 2, так как 52 = 25. Если же такой степени нет, то необходимо вывести сообщение «Не существует». К сожалению, ученик написал программу неверно.

Паскаль

var n,k: longint;
begin
  readln(n);
  k := 0;
  while k mod 5 = 0 do
    begin
    n := n div 5;
    k := k + 1;
  end;
  if k <= 5 then
  writeln(k)
  else
    writeln('Не существует');
end.

Последовательно вы­пол­ни­те следующее.

1. Что выдаст программа при вводе числа 125?
2. При вводе какого числа программа выдаст верный ответ? Укажите этот ответ.
3. Исправьте программу. Запишите ошибочную строку, затем не исправленной вариант. Помните, что нужно исправить имеющуюся программу, а не писать свою, хоть и с лучшим алгоритмом’

3.

Ошибка исправление
while k mod 5 = 0 do while т mod 5 = 0 do
if k <= 5 then if n=1 then

2. Дан массив. Необходимо найти количество соседних пар элементов таких, что оба числа из пары делятся нацело на 4. Объявлены переменные N, k, i, массив а из N элементов.

3. Паша и Валя играют в следующую игру: перед игроками лежит куча камней, каждый игрок за один ход может добавить в кучу 1 камень или удвоить количество камней в куче. Камни для ходов не ограничены. Выигрывает тот игрок, после хода которого в кучу оказалось 24 и более камней, но не более 38. Если после хода игрока в куче более 38 камней, выигрывает его соперник. Первым ходит Паша.

Пусть S — начальное количество камней в куче.
а) При каких значениях S Паша может выиграть первым ходом?
б) У кого есть выигрышная стратегия при S = 20, 21, 22.
в) У кого выигрышная стратегия при S = 10, 11?
г) У какого игрока выигрышная стратегия при S = 9? Нарисуйте дерево решений.

4. На вход даны пары чисел. Нужно выбрать из каждой пары по одному числу так, чтобы сумма всех выбранных чисел не была кратна 4 и при этом была максимально возможной. Напишите программу, выводящую такую сумму на экран. Если же ее невозможно получить, выведите 0. Баллы начисляются за ту из подзадач, что решена на большее количество баллов. Задача А дает 2 балла, задача Б — 4 балла. В задаче А приведите неэффективный алгоритм. При решении указывайте, какую подзадачу делаете. За алгоритм, неэффективный по времени ИЛИ памяти, дается 3 балла, по времени И памяти — 2 балла.

Задача А. Количество пар известно заранее и равно 6. Числа не превышают 30 000.

Задача Б. Количество пар N не известно заранее и может принимать значения 2 <= N <= 200 000. На вход подается сначала количество пар, затем сами пары. Числа по модулю не превышают 30 000.

Добавить комментарий